Back to overview
False alarm
Sep 12 at 04:50am NZST
Affected services
AutoTrader Platform
Resolved
Sep 12 at 04:50am NZST
The website was operational during this time, false positive.
Affected services
AutoTrader Platform
Resolved
Sep 12 at 04:50am NZST
The website was operational during this time, false positive.
Affected services
AutoTrader Platform